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Opinnäytetyö esittelee DMS600-ohjelman rakennetta ja kuinka kommunikaatio ta-
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välillä.  
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This thesis is made for ABB Oy, Grid Automation Systems.  

At the moment integrated a DMS600 project with MicroSCADA SYS600 is done 

by dedicated engineers and in two separate ABB locations. This thesis was made 

to clarify the main steps of an integrated project of DMS600 and decrease work 

travel and to ease work load by project engineers. 

This thesis introduces architecture of DMS600 and how the communication hap-

pens internally and between DMS600 and MicroSCADA or other SCADA sys-

tem.  

The thesis result clarifies how integrated DMS600 project is done and what infor-

mation is needed for the basic DMS600 project. 
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ABBREVIATIONS 

 

 

ABB Multinational company which produces electrical devices 

and systems 

 

AMR    Automatic meter reading 

 

API    Application Programming Interface 

 

DMS   Distribution Management System 

 

DMS600  MicroSCADA Pro Distribution Management System  

 

DMS600 NE   MicroSCADA DMS600 Network Editor 

 

DMS600 SA  MicroSCADA DMS600 Server Application  

 

DMS600 WS  MicroSCADA DMS600 Workstation 

 

GSM   Global System for Mobile communications 

 

OPC OLE for Process Control (OLE = Object Linking and Em-

bedding)  

 

HSB Hot Stand By is a redundant system 

 

SCADA   Supervisory, control and data acquisition 

 

SCIL Supervisory Control Implementation Language  

 

SQL Structured Query Language 

 

SYS600 MicroSCADA Pro SYS600 

 

WMS Web Map Service 

 

XML  Extensible Mark-up Language  
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1 INTRODUCTION 

1.1 Objective of Thesis 

This thesis was made for ABB Grid Automation Systems. The objective of the the-

sis was to clarify the integrated project of MicroSCADA Pro SYS600 and Mi-

croSCADA Pro DMS600 systems. Typically, each engineering part has been done 

by dedicated engineers. Currently these engineers are in separate ABB offices and 

locations. 

The first part of the thesis introduces the basic knowledge about MicroSCADA and 

DMS600. After that the functionality of DMS600 is discussed.  The last part of this 

thesis clarifies engineering process principles on DMS600. 

 

Figure 1. Architecture of DMS600 project 
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2 ABB 

ABB is the world`s leading pioneer of power and automation technology company. 

The headquarters are located in Zurich, Switzerland. The company employs world-

wide approximately 135 000 people in over 100 different countries. ABB`s busi-

ness activities are divided in four global divisions units. These units are Electrifica-

tion Products, Discrete Automation and Motion, Process Automation and Power 

Grids. /1/ 

 

2.1 ABB in Finland 

 In Finland ABB has business activities in 20 different locations. The factories of 

ABB are in Hamina, Helsinki, Vaasa and Porvoo. ABB in Finland employs approx-

imately 5000 people. Because of that ABB is one of Finland`s largest industrial 

employers. /1/ 

 

2.2  ABB Grid Automation 

The Grid Automation is part of the ABB Power Grid division. The Grid Automation 

business unit designs, markets and delivers Supervision Control and Data Acquisi-

tion systems (SCADA). The Grid Automation unit offers these SCADA project so-

lutions to electricity companies, industrial and infrastructural project, such as rail-

ways, airports and tunnels. The Grid Automation business unit also offers technical 

support, maintenance, training service and spare part service. /2/ 
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3 MICROSCADA 

3.1 MicroSCADA Pro SYS600 

MicroSCADA Pro is SCADA (Supervisory, control and data acquisition) software 

designed by ABB.  ABB originally designed this supervision software for control-

ling and monitoring substation automation and network supervision but nowadays 

it can be also used to control and monitor different kind of non-electrical applica-

tions. These applications can be railroads, district heating/cooling, gas-, oil and wa-

ter distribution. /3/ The MicroSCADA system has been up and running for over 30 

years and delivered worldwide. /4/ 
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3.2 MicroSCADA Pro DMS600 

MicroSCADA Pro DMS600 is a distribution network management system designed 

by ABB where distribution networks can be viewed on detailed geographical maps 

in raster or vector formats as well as in a schematic diagram.  

 

 

Figure 2. The geographical user interface of DMS600 WS 

 

 

MicroSCADA DMS600 is used for network control and distribution management 

task.   

The software can be used with MicroSCADA or without MicroSCADA or with 

other SCADA systems. DMS600 contains a high-level interface to MicroSCADA, 

which provides real time and static transfer. /5/ 
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4 ARCHITECTURE OF MICROSCADA DMS600 

4.1 General 

Integrated DMS600 systems usually include several computers and servers. These 

can be physical or virtual. A typical integrated DMS600 project has two DMS600-

servers and a separate SYS600 computer which has the OPC client installed. Also, 

a separate SQL server or cluster is possible. The system hardware varies between 

different projects. /6/ 

 

 

Figure 3. Architecture of DMS600 project integrated with MicroSCADA 
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4.2 Network Editor 

DMS600 Network Editor is the administrator`s tool for managing only the network 

data and SCADA interface with restrictions. 

The important tasks of DMS600 NE program are: 

 Creating binary database to DMS600 WS 

 Commissioning of background maps 

 Digitizing the network 

 Defining of components 

 Management of the integration between DMS600 and SCADA systems and 

other administrative tasks.  

In NE Administrator, it is possible to edit or add components to the network at the 

same time when the system is running. For linking OPC object between SYS600 

and DMS600 there is an External OPC DA Client Configuration Tool. /7/ 
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4.3 Workstation 

DMS600 Workstation is the operator`s tool for monitoring and operating medium 

and low voltage distribution networks.  

The main operational features provided by DMS600 WS are: 

 

 Network topology management 

 Network analysis 

 Alarming 

 Fault management 

 Field crew management 

 Outage management  

 AMR meter data management 

 Data analysis 

 Customer service 

 Document archive 

 Map printing /7/ 

 

 

The integration of DMS600 and MicroSCADA  makes a base for network topology 

management. Every change in the state of the switches or line sections causes an 

update on network topology. Both DMS600 and MicroSCADA can send infor-

mation about the changes to the network topology. The coloring of the network 

topology is a way of clarifying the network management. The color can represent 

different kind of information. For example, adjacent feeders can be different colors 

or an unsupplied line section.  
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The network analysis function offers fault current and power flow calculations, pro-

tection analysis and operational simulations. These calculations can use measure-

ment data which have been provided by SYS600. 

 For these calculations, needed information from the customer is annual energy con-

sumption, load curves, type of conductor used and length of the cable. The protec-

tion analysis needs information about protection relay parameters and medium volt-

age fuses./8/ 

The main function of the outage management is to create a complete outage report 

when a fault or maintenance outage takes place. Most important information that 

the report includes is how many unsupplied customers there are and when the 

maintenance outage or fault ends.  

When a fault takes place, the fault management starts calculating the fault location. 

At the same time the Distribution Management System sends information about the 

fault to a web service. This web service launches an external application that sends 

GSM messages automatically or manually to all customers in the unsupplied area. 

After the fault is located, fault isolation and power restoration planning starts. This 

is an automatic function if there is all needed information available. In the DMS600 

WS it is possible to execute the planned switching sequence. When the fault is fixed, 

the report about the fault is saved into the fault archive. /8/ 
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4.4 Server Application  

DMS600 SA is a Windows based service. Server Application provides information 

from MicroSCADA for the DMS600 Workstation instances.  

The main operational features provided by Server Application are: 

 Write coming fault from SCADA 

 Write feeder color state 

 Write changes of the switch position 

 

Server Application writes the faults and reclosing operations in the DMS database. 

Server Application receives this data from SYS600 via the OPC client or fault ser-

vice. /6/ 

4.5 DMS Socket Service 

Serving communication routines for the DMS600 program is the main function of 

the DMS Socket Service. The DMS Socket Service is a communication server be-

tween workstations. The socket service is crucial part of DMS600 messaging be-

cause all messages is routed through it. This service can deliver all MicroSCADA 

information data to DMS WS and commands from DMS WS to MicroSCADA via 

the DMS600 Service Framework OPC client service. /7/, /9/ 
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4.6 DMS600 Database 

The essential part of the DMS600 software is a database. The database contains 

information about the components, lines and customer data of the distribution net-

work. MS SQL Server and Oracle can be used as a relational database server to 

store the data. 

DMS600 usually needs one or two databases. In a domestic project, there are usu-

ally two databases. The first database contains static information and the other con-

tains dynamic information about the distribution network. One database which con-

tains all network information is popular at new foreign projects. /7/ 
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4.7 DMS Service Framework 

DMS Service Framework is a support process. The process ensures that needed 

modules will communicate with each other and all modules are running without 

failure. Service Framework does not have a user interface but a separate software 

DMS600 Service Monitor can be used to connect for all the Service Framework 

instances in the system. The service monitor can view the status and their logs e and 

modify settings and restart modules. 

The main services that Service Framework includes: 

 OPC Client 

 Interfaces to other systems 

 Fault Service 

 Outage XML Exporter 

 Topology Updater  

 Localizing the workgroup 

 GSM service to customer/7/ 

DMS Service Framework provides interfaces for other systems. These systems can 

be Automatic Meter Reading System, Outage XML Exporter and WMS, for in-

stance. WMS provides a simple interface for requesting map images from distrib-

uted geospatial databases. 

The fault service sends information to the DMS600 which will determine if it is a 

fast reclosing operation, a delayed reclosing operation or a fault. The topology up-

dater checks changes from the state of the switches. /9/ 
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4.8 Communication between DMS600 and SCADA Systems 

There are three internal communication interfaces in the DMS600 and countless 

external interfaces. The SCIL API- and OPC interface are used for communication 

between DMS600 and MicroSCADA. DMS600 uses mainly the OPC interface to 

communicate because the SCIL-API communication interface is obsolete. For in-

ternal the communication interface DMS600 uses the DMS socket service as a mes-

sage routing component. /9/ 

 

Figure 4. Communication interfaces between DMS600 and MicroSCADA 
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5 ENGINEERING PROCESS PRINCIPLES ON DMS  

5.1 Main Steps for Creating of the DMS600 Project 

The integrated DMS600 project with MicroSCADA needs an existing Mi-

croSCADA application, network data and background map material. If the project 

has service, such as network analysis, fault management or AMR meter data man-

agement, then the project needs data from the customer information and load 

curves. The DMS600 project can be created with or without MicroSCADA or other 

SCADA systems. Before starting the project, it is essential to know which services 

have been sold; if it is an existing system and what kind of systems it is and how to 

integrate with it. /6/ 

 

Main steps for creating of the DMS600 project is explained in next chapter. (Figure 

5.) 
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Figure 5. Process chart of the integrated DMS600 project 

 

1. To start a new DMS600 project install these following programs: DMS600, 

SYS600 and SQL server. Install the needed project specific support soft-

ware for DMS600. It depends on the project which support software is 
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needed. One example of this support software is Windows Office for cus-

tomer listings and switching plans, for example for example lists of switch-

ing device operations for field crews. /6/ 

 

2. Background maps for the domestic DMS600 projects can be acquired from 

the National Land Survey of Finland (Maanmittauslaitos) and for the export 

projects there are different ways to acquire background maps. Acquiring 

backgrounds maps to exports project can be challenging.   

 

For export projects Openstreetmap and WMS server are services where 

needed background maps can be acquired. Also, the customer can be asked 

to acquire needed background maps. 

 

 

3. Convert all background maps to a correct format, raster maps into BMP 

(Windows bitmap format) and vector maps into the AutoCAD DXF format. 

Adjust these maps to a single orthogonal orientation. The Coordinate Sys-

tem must be defined for each map layer before installing and adjusting back-

ground maps. A different map scale is needed for zooming between the 

overview map and more the detailed map.  
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Figure 6. Adjusting map scale and zooming level. 

 

The DMS map loader and QGIS program are tools for reading and adjusting 

background maps. A tool has been developed in the Python code for reading 

the WMS server. This tool converts map pieces into the right coordination, 

saves into the files and writes them at DMS600 root. /6/ 

 

 

4. Create the required MicroSCADA station pictures and process database. 

This can be done at the same time as converting maps to DMS600. 
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5. Create the distribution network database with DMS600 NE. The database 

contains data about the substation, lines and components. The most effective 

way create a network database is with importer tools.  

 

Common import software tool to import network data are: 

 DXF Importer 

 Becos import  

 PG import file 

 

The most common import tools are DXF- and Becos import tools but these 

software tools can only import all network data once into DMS600. After 

importing, DMS600 NE keeps the network data. The PG import file imports 

the network data from a text file. The PG import file can import repeatedly 

all network data into the DMS600 without other engineering after the first 

installation. Under development is ESRI Shape File Import and KML Im-

port tools, which can also do that.  

DMS600 NE can edit and add network database manually, if necessary. The 

creating and updating of network database is only allowed in the data edit 

mode DMS600 Network Editor. /6/ 
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Figure 7. Adding the line in to DMS600 
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To add the new network line into the DMS600 

 

 Click Edit> New line  

 Insert the new line start node where you want to start drawing the 

line and define the node.  

 Select the Voltage level for the line  

 Draw the line by clicking the assumed route of the line. Right-click 

at the ending point of the line 

 Insert the data of the start component 

 Insert the data of line 

 Insert the data of the ending component 

 

The DMS Network Editor automatically fills in the length of the line, pre-

sumed voltage level and conductor type. The voltage level and presumed 

conductor type depends on the last connection of the line. /7/ 
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6. Import the needed MicroSCADA pictures to the DMS600 network data-

base. Normally internal control and station diagrams are converted from 

MicroSCADA. When importing some process object names are updated au-

tomatically, for example circuit breaker. These pictures can also be created 

in the DMS600 Network Editor. 

 

 

Figure 8. Import station picture in SYS600 for DMS600 
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To import MicroSCADA station picture to DMS600 

 

 Open MicroSCADA and select picture to import 

 Go to Tools > Engineering Tools > Display Builder 

 Edit the picture desired form 

 Then click Action > Build DMS Import File  

 Go to the DMS600 NE  

 Click import and select the needed picture. The type of the picture 

file is IS6G. 

 Adjust the station picture into the background map 

 

After importing, connect the network into the feeders of the station manu-

ally and check that they are correct. There is an automatic station feeder 

connection being planned. After the connection to MicroSCADA the pic-

tures do not change the logical name or OPC address of the switching de-

vices or line indicators. /7/ 
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7. Defining measurement values 

 

The measurement values from MicroSCADA can be linked at DMS WS and 

monitor in real time. DMS600 WS uses measurement values to make the 

network analysis more accurate.  

Figure 9.  Measurement data form where to define specific measurement 

settings. 
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To add manually a measurement to DMS600 

 Open the DMS NE and Click Edit > Add Measurement 

 Click the network window where you want to measurement box to 

be.  After that the measurement data forms open  

 Add the real power measurement manually into the type of measure-

ment box 

 To define the measurement object more accurately, use the Prefix, 

Unit, Factor, Decimal place and Default value for defining the ob-

ject. 

 Click Connect and then click the measurement node to make a con-

nection between the selected node and the measurement node 

 Update the binary database 

 Open DMS600 External OPC DA Configuration Tool 

 File > Fetch DB Data 

 Click Connect at OPC Servers MicroSCADA – Measurements 

 Open the Measurement tree 

 Select the needed measurement and drag this measurement into OPC 

address 

 Right click OPC Server Set Value MicroSCADA - Measurement  

 Go to the measurement data forms and add the OPC name for the 

measurement 

 Restart the OPC client 
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To add several MicroSCADA measurements to DMS600 

 Open External OPC DA Client Configuration tool 

 Click Fetch names recursively at the measurement section 

 Connect the measurement section 

 Write `filter` at the item filter for filtering needed measurement. ex-

ample \\APl\1\P\RIVH 

 Check that the measurements are correct then click Store Available 

Items  

 Restart DMS600 NE 

 Open the DMS Ne and Click Edit > Add Measurement 

 Click the network window where you want to measurement box to 

be. After that the measurement data forms open  

 Select the OPC name for the measurement  

  The type of the Measurement can be defined in the type box. Defin-

ing the measurement type is important if the measurement is needed 

in the network calculations of DMS600 WS. 

  To define the measurement object more accurately, Use the Prefix, 

Unit, Factor, Decimal place and Default value for defining the ob-

ject. 

 Click Connect and then click the measurement node to make a con-

nection between the selected node and the measurement node 

measurement must connect feeder node if not a bus bar. /7/  

file://///APl/1/P/RIVH
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8. Setting up project specific settings  

 

DMS600 project specific settings vary between different projects and ac-

cording to the licenses and equipment sold in the project.  

 

The project specific settings are 

 zoom level of background maps 

 symbol setting  

 network color 

 settings of outage planning 

 settings of fault location 

 regions and user level settings 

 configuration of interfaces for external software for example for 

GSM- message system 

These settings need project specific engineering. /6/ 
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6 CONCLUSION 

The aim of this thesis was to clarify integrated DMS600 project principles. This 

thesis helps to understand how the project structure works and what information is 

needed for basic integrated DMS600 project. 

The workflow of this thesis was first to get to know how to MicroSCADA pro 

DMS600 works, then to clarify integrated project principles. Thanks to ABB’s 

Tampere office group for providing information for MicroSCADA Pro DMS600 

and project structure. 

When I was working on thesis I received a good view on how MicroSCADA 

DMS600 works and what main project principles are. I hope that in the future I can 

improve my skills in integrated project and assist the DMS600 project engineers in 

Tampere.  
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