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TIIVISTELMÄ 

Oulun ammattikorkeakoulu 
Tieto- ja viestintätekniikan tutkinto-ohjelma, ohjelmistosuunnittelija 
 

 
Tekijät: Henri Vesterinen, Matias Kyriacou 
Opinnäytetyön nimi: Unity Essentials 
Työn ohjaaja: Pertti Heikkilä, Roberto Hanaş 
Työn valmistumislukukausi ja -vuosi: Kevät 2019 Sivumäärä: 48 + 12 
 

 
Opinnäytetyön pääasiallinen tavoite oli nopeuttaa tulevien Oulu Game Lab opiskelijoiden 
pelinkehitystä tarjoamalla heille liitännäispaketti, joka sisältää olennaiset työkalut 
mobiilipelikehitykseen, kuten monetisaation, Google Play toiminallisuuden ja analytiikan. 
Liitännäispaketin pyrkimys oli myös olla mahdollisimman käyttäjäystävällinen ja sisältää 
testinäkymiä, joilla paketin toiminnallisuutta voi esitellä ja testata. Työn tilasi Oulu Game Lab. 
 
Työ alkoi keräämällä taustatietoa ja valitsemalla mitä osia paketti tarvitsisi. Taustatieto koostui 
useista alan julkaisuista ja aiheeseen liittyvistä tutkimuksista, joista koostettua dataa hyödynnettiin 
työn valintojen tekemiseen ja perustelemiseen. Työn projektiosuus toteutettiin Unity-moottorille C#-
kieltä käyttäen. 
 
Työn tuloksena saatiin valmiiksi toimiva liitännäispaketti testinäkymineen, joka voidaan ottaa 
käyttöön OGL opiskelijoille. Luodun liitännäispaketin toimivuus testattiin esittelemällä ja 
opettamalla sen käyttö tämänhetkisille OGL opiskelijoille suunnatussa työpajassa. Työn 
vaikutuksia ja käyttöönottoa tuleville opiskelijoille ei voitu dokumentoida työn aikarajan puitteissa. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Asiasanat: Unity, liitännäinen, Android, Google Play, monetisaatio, mikromaksut, analytiikka, 
pelinkehitys  
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ABSTRACT 
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The main aim of the thesis was to hasten the game development of future Oulu Game Lab students 
by providing them an asset package that includes core mobile game functionalities, such as 
monetization, Google Play functionality and analytics. The asset package was set to be user-
friendly and to include an example scene for the easy demonstration of the features of the package. 
The thesis was commissioned by Oulu Game Lab. 
 
The work began by gathering background info and choosing which plugins to include in the 
collection. The background info comprised of several IT publications and related studies, from 
which the collected data was used for making educated choices in the project and to justify 
decisions. The project part of the work was done for the Unity engine using the C# language. 
 
As a result of the work, a working asset package with the required example scenes was finished 
and can be put into use by OGL students. The usability of the asset package was tested by 
showcasing and instructing the use of it in a workshop directed at current OGL students. The effects 
of the work and its implementation by future students could not be documented in the timeframe of 
this work. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Keywords: Unity, asset package, Android, Google Play, monetization, microtransaction, analytics, 
game development 
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1  INTRODUCTION  

The thesis was ordered by Oulu Game Lab (OGL). The aim of the thesis was to develop a Unity 

plugin package (henceforth referred to as an “asset package”, in accordance with terminology used 

by Unity) for new OGL students to speed up their game development, especially during the early 

development phases where the schedules are tight due to the nature of OGL. The asset package 

will include implementation for functionality such as advertisements, monetization, analytics and 

saving. In addition, it will also feature an example scene which demonstrates and allows the testing 

of the features of the asset package to the user. The work will be divided between the two workers. 

Matias Kyriacou will work on monetization, including advertisements and in-app purchases (IAP), 

push notifications and cloud saving while Henri Vesterinen will work on GameAnalytics and 

integrating Google Play Games Services (GPGS) functionality to the asset package, including sign 

in, achievements and leaderboards and the minigame which will be used to demonstrate different 

features of the asset package. Both workers will also build the relevant UI pieces for their share of 

the work and pieces of the example scenes that use features they implement. 
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2 BACKGROUND KNOWLEDGE  

2.1 Unity 

Unity is a cross-platform real-time engine developed by Unity technologies. It was initially released 

on June 8th, 2005. It currently supports 27 platforms and is used to create both 2D and 3D games. 

The main scripting language used for Unity is C#. Since 2016, Unity has also started offering cloud-

based services for developers such as, Unity Ads, Unity Analytics, Unity IAP and Unity Multiplayer. 

(1.) 

2.2 Google Play 

Google Play is a digital distribution service for Android apps, games, music, movie rentals and 

purchases, and e-books. Google Play was launched on March 6, 2012, combining the Android 

Market, Google Music and the Google eBooks store under one brand. In 2017, Google Play 

featured 3.5 million Android applications, and the said applications could be purchased in 145 

countries. Developers have to pay a one-time 25$ registration fee to use this service. Developers 

control in which countries the app is distributed in and the pricing for the app and possible in-app 

purchases, the developers gaining 70% of the revenue. (2.) 

 

The GPGS offers a great deal of features that are useful for most Android games, such as sign in, 

achievements, leaderboards and cloud saving. Google Play Games allows the developers to 

include the above features in their games conveniently without using resources on developing the 

said features. The Google Play Games was released in July 24, 2013. (3.) 

2.3 GameAnalytics 

GameAnalytics is a free analytics tool that provides developers with real-time data analytics and 

an easy-to-use plugin for simple implementation. GameAnalytics provides a browser UI for viewing 

data and an easy plugin for Unity for implementing data gathering. It was founded in 2011 by Morten 

Wulff and in 2018 GameAnalytics launched an updated platform with a fully developed backend 

solution and several feature enchantments. (4.) 
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3 SPECIFICATIONS  

3.1 User-friendly 

The aim of this project was to make an asset package that would include all the functionality 

necessary for mobile game development, which in this project includes monetization with 

advertisements and in-app purchases, analytics of data acquired from players playing the game, 

push notifications and the GPGS package. The GPGS package contains sign-in to Google Play, 

achievements, leaderboards and cloud saving. In addition, the written portion of the project includes 

instructions for getting started with the Google Play Console for developers to open access to the 

functions provided by Google for mobile app development and to upload a mobile game to Google 

Play. 

 

As the time constraints during the early parts of OGL were very strict, a key point in the project was 

to allow users to implement these functionalities into their projects as fast as possible. In addition 

to just making the scripts as easily understood as possible, a user interface will be made that 

minimizes the amount of work required in the implementation as it should allow the user to do all 

the work through the menus, without having to work with the scripts at all, unless some changes or 

customization to them is needed. 

3.2 Example scene 

The asset package will also feature a set of example scenes that demonstrates all the different 

features the package contains. This will require a splash screen which will be used for initializing 

all the necessary scripts, a main menu from which the user can access a minigame, leaderboards 

and a shop. In between the scenes there will be loading screens which will be used to demonstrate 

the ad functionality. 
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4 TOOLS AND METHODS 

4.1 Project management 

The project utilized the Scrum framework. The work was done by iteration and the project was cut 

into 2-week sprints in accordance with Scrum. Both workers developed one small piece at a time 

and then moved on to the next one. 

4.1.1 Pivotal Tracker 

The agile project management tool pivotal tracker was used for keeping track of the progression of 

the project. Pivotal tracker is a project management tool created by Pivotal Labs.  

4.1.2 Gitlab version control 

In this project Gitlab was used for the version control. On top of the basic functionality provided by 

most repository hosting services, i.e. easy access to project files and collaboration between project 

members, Gitlab was chosen because it allows private repositories for basic users. GitLab is an 

open source web-based Git repository manager which provides wiki, issue-tracking and a CI/CD 

pipeline. It is used by many large tech companies, such as IBM, Sony, NASA and Boeing. (5.)  
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4.2 Development environment 

4.2.1 Unity 

As Unity Essentials is an asset plugin for Unity, thus Unity was a part of our development 

environment. Unity is a cross platform game engine which is developed by Unity Technologies. 

Unity allows users to create 3D and 2D games and offers a primary scripting API primarily in C#. 

Unity has one free and 3 paid licensing options. (Figure 1.) 

  

 

FIGURE 1. Unity licensing options 

The Free license includes all engine features and build platforms and allows a yearly revenue 

capacity of 100,000$ which, in addition to its comprehensive manual and good support provided 

by its large community, makes it ideal for startup game companies and students. (6.) 

4.2.2 Google Play 

Due to the workers’ close familiarity with the Android features provided with Google Play, they were 

chosen to be included in this asset package. The features, such as Sign In, Achievements, 

Leaderboards and cloud saving, use Google Play’s application programming interface (API) to 

function.   

4.2.3 GameAnalytics 

GameAnalytics was chosen as the analytics tool because of the close vicinity of OGL and Fingersoft, 

and more specifically due to Fingersoft’s publishing wing Round Zero, which often co-operates with 

OGL teams working on mobile game projects. Round Zero requires the OGL teams to implement 
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analytics tracking to their projects if they wish to establish talks regarding publishing their projects 

through Round Zero. As Round Zero uses GameAnalytics themselves, co-operation is more 

seamless if GameAnalytics functionality is offered in this plugin. Another option would have been 

to use the built-in analytics capabilities of Unity, which would have cut down the number of plugins 

needed, but it was decided that the opportunities provided by collaborating with Fingersoft take 

precedence. 

4.2.4 Visual Studio 

Visual studio was chosen as the integrated development environment (IDE) because it naturally 

supports C# and due to its familiarity to the project workers. 
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5 PROJECT 

5.1 Monetization  

In the modern gaming landscape that is leaning more and more towards the free-to-play mobile 

market the need to find a balance between monetization and player freedom is greater than ever. 

(Figure 2.) While mobile games have existed in some form since the late 90s with the massive 

success of Nokia’s Snake (7.), the small screens, limited technology and lack of constant high-

speed internet connections made the pre-smartphone mobile gaming market a very different place. 

The modern era of mobile gaming did not truly come into its own until the advent of smartphones 

with touch screen capabilities and reliable internet connections around the turn of the last decade. 

As such, the modern iteration of the mobile gaming market is a young one, still suffering from 

constant growing pains and fast changes. One of the main things these constant changes affect is 

monetization, which includes advertisements and in-app purchases. 

 

 

FIGURE 2. Video game market share per platform 2018 (8.) 
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5.1.1 Advertisements 

 

While the underlying principle of advertisements has remained the same, i.e. signing a contract 

with an advertising network and then implementing a system, which displays advertisements from 

the said network and gaining revenue based on advertisements watched or clicked, the way these 

advertisements are presented to players has drastically changed over the years (9.). 

 

 

FIGURE 3. Angry Birds banner advertisement (10.) 

Common ways of advertising in early modern mobile games, such as Angry Birds from 2009, often 

used constant banners and intrusive pop-ups to make sure the player saw the advertisements. 

(Figure 3.) Forcing the advertisements on the player was successful in the sense that the player 

had no choice in if they wanted to see them or not, guaranteeing ad revenue. With time, incentivized 

advertisements and other less intrusive ways of advertising that do not interfere with the players’ 

immersion have started to take over. Incentivized advertisements refer to advertisements that the 

player can choose to watch and which result in benefits for the player, such as in-game currency 

or other free content, thus eliminating the frustration from being force-fed advertisements. Still, 

incentivized advertisements have yet to replace other forms of advertisements completely. 

 

A real-life use case of incentivized advertisements can, for example, be found in Hill Climb Racing 

2. When opening free loot boxes gifted to the player at certain times, the boxes can contain extra 

items that are unlocked by watching an ad. (Figure 4.) The first Hill Climb Racing also used banner 
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advertisements, which the second game moved away from, showcasing the evolution of mobile 

advertising. 

 

 

FIGURE 4. Extra items in a loot box are unlocked by watching an ad (11.) 

Another very common solution is interstitial advertisements, which as the name implies, are played 

between parts of gameplay, usually after levels, during loading screens or other such natural 

pauses in gameplay. These advertisements are displayed full screen and offer more freedom to 

the advertiser in terms of content displayed, such as integrating interactive elements (12.). Google 

currently offers a comprehensive guide to implementing interstitial advertisements in the correct 

way as to minimize the amount of intrusion occurred on the player. (Figure 5.) (Figure 6.) 
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FIGURE 5. Disallowed interstitial usage (13.)  

 

FIGURE 6. Recommended interstitial usage (14.)  

For the purposes of this thesis, UnityAds was chosen as the advertisements network, as it is a built-

in part of Unity and has a simple setup procedure. UnityAds currently supports only full screen 

video advertisements, which can be customized to fit the description of either interstitial or 

incentivized advertisements. As outlined by the best practices guide by UnityAds, the service works 

by holding an open auction every time a game requests an ad and showing an ad from the highest 

bidding advertiser. 
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5.1.2 IAP 

 

As with advertisements, the implementation of IAP into mobile games has also seen drastic 

changes over the years, shifting from a focus on selling lives and stamina, to more intricate systems 

like gacha/hero collecting/loot boxes and skins for player characters. (Figure 7.) (Figure 8.) As of 

2018, three of the five highest grossing iOS mobile games worldwide, Monster Strike, F/GO and 

Puzzle & Dragons, heavily implement a gacha system into their gameplay (15.). Even though these 

chance-based systems have been proven successful in a monetary sense, they are not without 

their problems, as many critics see these systems as a form of gambling in need of regulation. 

Based on the study of The Gambling Commission, the number of children with gambling addictions 

has quadrupled between 2016 and 2018, which Professor Mark Griffiths from the Nottingham Trent 

University attributes to the rise of chance-based systems in video games in his piece for The 

Conversation. (16.) 

 

 

FIGURE 7. Selling lives in a mobile game (17.) 

These chance-based systems are most often built around differing currency systems, where the 

player purchases so called hard currency which can then be exchanged for premium services in-
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game, such as the gacha. In Fate/Grand Order this hard currency, named Saint Quartz, can be 

used to expand the players inventory space, refilling stamina and mainly for “rolling” the gacha. 

(Figure 8.) 

 

 

FIGURE 8. Fate/Grand Order gacha (18.) 

5.1.3 Execution 

For implementing the advertisements and IAP, the built-in functionality Unity provides for these 

features as a basis was used. The implementation of the core IAP functionality was very simple, 

as the Unity IAP service contains all necessary functions for interacting with Google Play and 

making purchases. For the project, only a callback system for the IAP Button for when a purchase 

is completed to give the player the item they have purchased and save the item on their save data 

was needed to be built. (Figure 9.) (Figure 10.) 
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Figure 9. IAP Button provided by the Unity IAP service 

 

FIGURE 10. Callback function for IAP Button 

Implementing the advertisements was also made simple by the Unity Ads service, which handles 

contacting the ad provider, the ad UI and keeping track of the status of the ad. For our part, three 

different types of scripts that implement the Ads service, IncentivisedAd, InterstitialAdAutomatic 

and InterstitialAdRequirements were built. These three scripts all work in a very similar way, with 

the IncentivisedAd script requiring the player to finish the ad before rewarding them. (Figure 11.) 

On success, the script invokes a callback function in the same way the IAP Button does. In the 

example scene, the same BuySkin function is called. The difference between the two interstitial 

scripts is that the InterstitialAdRequirements allows customization regarding showing the ad, such 

as having it shown only in every fifth loading screen instead of every loading screen like with the 

automatic script. 
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FIGURE 11. ShowIncenvitisedAd.cs 

 

5.2 GameAnalytics  

Modern game development relies heavily on data and analytics, especially on mobile phones and 

data driven game design is becoming the norm. It is becoming increasingly important for even the 

smallest of game studios to implement proper analytics into their games to enable creating better 

game experiences and generating optimal profits. GameAnalytics is a service that enables easy 

tracking and analyzing of this type of data. (Figure 12.) 
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FIGURE 12. GameAnalytics Dashboard 

5.2.1 Execution 

Developing the GameAnalytics portion of the plugin started by researching on how to simplify the 

use of their current services even further. The modularity of analytics presented itself as a problem 

and creation of an object which would handle all analytics for the user without any programming by 

the user was not an option. In the end a GameAnalytics controller class that initializes 

GameAnalytics functionality was created. This controller uses existing GameAnalytics features as 

base. Examples of the function calls were added into the UI, which the user can easily copy into 

their code. (Figure 13.) In addition, relevant GameAnalytics function calls were included in all the 

existing objects that gather relevant data, so that the user will automatically see if a player uses the 

sign in button for example. 
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FIGURE 13. GameAnalytics User Interface 

5.3 Google Play Games Services  

GPGS is a service and development kit for online games on Android. It provides many features, 

such as sign in, could saves, leaderboards and achievements. A section was added into the manual 

for easy configuration of the Google Play services, which require resource definitions to function. 

(Figure 14.) 
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FIGURE 14. Google Play Games Configuration 

5.3.1 Sign in  

Most modern game features, such as progression tracking on a cloud save or IAPs, require some 

form of player identification. This is usually handled with a user sign in, and the easiest way to 

implement a user sign in on Android devices is via GPGS. (Figure 15.) 
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FIGURE 15. Fire Emblem Heroes Sign in screen (19.) 

5.3.1.1 Execution 

It was concluded that most games use either a sign in button or automatic sign in, and usually after 

the sign in action, the scene will change from the sign in scene into the first actual game scene. 

Implementing this was made as easy as possible. From this UI the user can add a sign in object 

into their scene. There are two options, automatic and button. The automatic sign in object will run 

the sign in script as soon as the scene starts and the sign in button will do the same when the 

button is pressed. 
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FIGURE 16. ShowSignIn.cs 

The sign in function is demonstrated above. (Figure 16.) When called, the function will use the 

Google Play services social class and tries to authenticate the player. If the attempt succeeds the 

player is allowed forward, and their save is initialized by UESaveManager. In case of a failed 

attempt, the platform is checked. In case of an Android device the function will do nothing, and the 

player can repeat the sign-in operation. In the case of a non-Android device, the player is let 

through. This is for testing purposes for Unity on PC. 

 

5.3.2 Achievements  

Trophies, badges, awards, stamps, medals, challenges, achievements have many names, yet their 

purpose always remains the same. First uses, which might be called, achievements can be tracked 

all the way back to 1982 when Activision would send physical patches to high scoring players. 

Achievements are a form of a meta-goal outside of game’s regular parameters, usually intended to 

boost the game longevity and to provide players with the impetus to do more than beat the game 

once. (20.)  
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5.3.2.1 Execution 

Players need to be able to see their achievements and unlock, reveal or gain progression on them 

depending on their type. There is no need for an extra interface for viewing achievements in game 

as the Google Play app provides an interface for viewing achievements for all the games the player 

has on their phone. The Google Play app is automatically installed on all Android devices. Code 

snippets were implemented for easy copy-pasting of function calls in this UI, allowing the user to 

easily unlock, reveal or progress achievements for players when needed. (Figure 17.) In addition, 

a section was added into the manual guiding the user to the right place in the Google Play Console 

for creating achievements.  

 

 

FIGURE 17. Achievements UI 

 

FIGURE 18. ShowUEAchievementsScript.cs 
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One of the achievement functions is demonstrated above. (Figure 18.) This function uses the 

PlayGamesPlatform functionality as base and passes on the parameters on to its function which 

proceeds to handle the progression of the achievement. The UEAchievement script initializes the 

PlayGamesPlatform so that the user does not need to initialize anything separately. 

5.3.3 Leaderboards 

Similar to achievements, leaderboards are another way to increase games longevity by adding 

replay value to the game, as the beating a high score that the game program, another player or 

oneself has set becomes the meta-goal for the player. High scores and therefore leaderboards 

have been around since the era of pinball machines and similar early leaderboard systems were 

introduced into video games as early as 1978 with the likes of Space invaders (1978) and Space 

invaders 2 (1979). (21.) (Figure 19.) 

 

 

FIGURE 19. High score screen (22.) 

5.3.3.1 Execution 

There are few things that are required for Leaderboards. Players will want to see the leaderboards 

and they also need to be placed in the leaderboards based on various metrics. The user can create 

a leaderboards object from the UI. This object is a button which will open Google play’s own 

Leaderboard interface. It shows all the leaderboards associated with the game to the player. In 

addition, example function calls were added into this UI so that the user can easily copy paste into 
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their code when they wish to record a player’s high scores. A section was added into the manual 

guiding the users to the right place in Google Play Console for creating Leaderboards for their 

game. 

 

FIGURE 20. ShowEULeaderboardmanager.cs 

The leader board manager contains two functions, ShowLeaderBoards() and 

UpdateLeaderBoard(). (Figure 20.) ShowLeaderBoards() will check if the player is authenticated 

and after succeeding, it will show the player the Google Play Games leaderboard UI, which contains 

all leaderboards created for this game entity. (Figure 21.) The UpdateLeaderBoard() function will 

take in score and leaderboardID as parameters and insert the given score to the leaderboard after 

confirming that the player is authenticated. 
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FIGURE 21. ShowUELeaderboards.cs 

 

5.3.4 Cloud saves  

Because a large portion of modern mobile games, and other modern video games in general, 

function under the so-called games as a service model, game saves are now more important than 

ever. The basis of the games as a service model is that a game is not finished after the initial 

launch, but rather keeps getting more content through updates, with the goal of sustained revenue 

(23.). Under such a model, having a player’s account and save data safe is extremely important as 

in ideal scenarios, the player has hundreds of hours of playtime and several purchases tied to their 

account. Some examples of the model in action include the strategy/city builder Clash of Clans and 

the naval warfare/hero collector Azur Lane. (Figure 22.) 

 

 

FIGURE 22. Azur Lane statistics screen (24.) 
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For a larger project, building a custom database and solution for accounts and saving data is 

common and more flexible compared to a readymade service. But in case of smaller teams, often 

with no budget to speak of, the cloud saving solution provided by Google is a simple and reliable 

solution and requires no extra payment on top of the Google Play developer account.  

5.3.4.1 Execution 

Even with the cloud saving support provided by Google Play, implementing this service was still 

not simple as Google Play only provides the servers and the API for interacting with the server, 

thus still requiring the users to build the logic behind the save game and putting the API to use. 

 

First, the size of the save file and the data to be stored in were decided based on the features of 

the example scene provided with the project. The save file itself is a simple integer array, with each 

element being used for storing different numerical variables, such as how much gold the player 

possesses or what cosmetic changes the player has enabled on their avatar. (Figure 23.) 

 

 

FIGURE 23. CloudVariablesExample.cs 

When the game has loaded the save, the values held in the array can be accessed with static getter 

and setter methods as to not provide direct access to the array for safety. (Figure 24.) The methods 

also have safety checks to make sure that nothing can go wrong during the reading or changing of 

the values. 
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FIGURE 24. CloudVariablesExample.cs 

Second, for initializing, saving and loading the data, a manager script was created. (Figure 25.) In 

the initialization method, the cloud saving API is given the required configuration and activated. In 

addition, the method is used for initializing player preferences, which is local data used for storing 

info such as changes to the game settings. As the saving needs to be initialized before accessing 

the actual game, the script has a system where the user needs to input the name of the first active 

scene in the game that will be used for initializing. If the script is run in a different scene, the data 

will not be loaded to avoid overwriting data in unsafe locations. 
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FIGURE 25. UESaveManager.cs 

If the initialization goes through, the data is then loaded from the server or from the local device. If 

the player has authenticated, i.e. logged onto their Google Play account with an active internet 

connection, the cloud saving is used. Otherwise the data stored locally on the device will be used 

instead. Depending on the type of game, local saves can be disabled completely as they can lead 

to conflicts with the cloud data and the local data can be tampered. (Figure 26.) (Figure 27.) (Figure 

28.) (Figure 29.)  
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FIGURE 26. UESaveManager.cs 

 

FIGURE 27. UESaveManager.cs 

 

FIGURE 28. UESaveManager.cs 
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FIGURE 29. UESaveManager.cs 

For saving the data, mostly the same process is used, but with the “saving” boolean of the 

OpenSave method set to true. After the data has been opened, the SaveGameOpened() method 

calls SaveDataToCloud() instead, when saving. (Figure 30.) 

 

 

FIGURE 30. UESaveManager.cs 

Finally, as the recommended data format for Google Play cloud saving is JSON, a premade JSON 

plugin was added to the project to parse JSON to an array and vice versa. (Figure 31.) (Figure 32.) 

(Figure 33.) 

 

 

FIGURE 31. UESaveManager.cs 
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FIGURE 32. UESaveManager.cs 

 

FIGURE 33. JSONUtil.cs 
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5.4 Push Notifications  

5.4.1 Introduction 

Push notifications are notifications that are displayed outside apps, in the notification drawer. 

(Figure 34.) They can be sent by apps to give the player reminders, info or messages relating to 

the app that is sending them. For example in games with a stamina system, the game can send 

the player a push notification when their stamina is back to full after a gaming session has depleted 

it. As noted by Urban Airship in their study of push notification effects on mobile app retention, 

sending players relevant push notifications at least once a week has a massive positive impact on 

retention numbers (26.). 

 

 

FIGURE 34. Example of a push notification 

5.4.2 Execution 

Compared to every other feature implemented in this project, push notifications are the hardest to 

implement without the use of an existing asset package as Unity has no native support of the 

feature. As such, for this project a readymade asset package was chosen for ease of use. For 

sending push notifications, the user only needs to call one of the available methods in the provided 
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NotificationManager script. (Figure 35.) The project does not provide any system for more complex 

scheduling, so users need to create their own solution. 

 

 

FIGURE 35. MainScreen.cs 

 

5.5 Example scenes 

It was specified that the project is to include a set of example scenes which demonstrate the 

functionality and features of the asset package. For this purpose, example scenes start, main, 

game and shop were created.  

5.5.1.1 Start scene 

The main function of the Start screen is to host the Unity Essentials gameobject and AutoSignIn 

object. The UnityEssentials gameobject has a do-not-destroy script which prevents it from getting 

destroyed when loading a new scene. (Figure 36.) The UnityEssentials Gameobject will initialize 

its scripts at the start of the scene and then deliver their functionality to the following scenes. Unity 

Essentials game object itself hosts Unity Essentials Manager, UE Leaderboard Manager, UE Save 

Manager, and Loading screen scripts. The AutoSignIn object includes the Sign In script which 

handles the automatic signing in. It will attempt to connect to Google Play and authenticate the 

player. When successful it will tell the loading screen script to transfer the player to the main scene. 
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FIGURE 36. UnityEssentials gameobject 

Unity Essentials Manager  

 

The Unity Essentials manager script Initializes and stores values that are used by other managers 

and scripts. 

 

UE Leaderboard Manager 

 

The leaderboard manager script manages updating and showing the leaderboard to the player. Its 

functions are later called by the show leaderboards button and at the end of game scene to update 

the player’s score to leaderboards. 
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UE Save Manager 

 

The save manager script initializes variables required for cloud saving and includes functions 

loading and saving data to the cloud. These functions are called later when the player buys skins 

or sets a preferred skin and when the game is started. 

 

Loading Screen 

 

The loading screen script handles all scene changes. Its functions are later called when signing in, 

or when the player presses start game or shop buttons.  

5.5.1.2 Main scene 

The Main scene features 4 buttons with different functionalities. The Start Game button will transfer 

the player into the Game scene, the Shop button will transfer the player into the shop scene, the 

Leaderboards button will call leaderboard manager to show the Google Play leaderboard UI, and 

finally the reset save button which is used to erase all saved data from the cloud. (Figure 37.) 

 

 

FIGURE 37. MainScene 
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5.5.1.3 Game scene  

For the purpose of demonstrating leaderboards, a very simple game of dodging columns was 

created for the Game scene. (Figure 38.) The player square will move forward and encounter 

procedurally generated obstacles. The player will earn points each time they can get past an 

obstacle. If they collide with an obstacle, they will lose and they are transferred back to the main 

scene through a loading scene, the loading scene will play and add for them at this point. As the 

player loses, their score will be recorded into the high score list, which can be displayed from the 

high scores button from the main scene. 

 

 

FIGURE 38. GameScene 

5.5.1.4 Shop scene 

The shop scene features a number of buttons that allow the player to buy and change the skin of 

their square. (Figure 39.) Yellow, green and blue skin can be bought with real money and the red 

one requires the player to view an advertisement before they can unlock it. The buying buttons are 

created with Unity IAP, and after a successful purchase, the shop script determines what exactly 

is unlocked for the player. (Figure 40.) 



  

41 

 

FIGURE 39. ShopScene 

 

FIGURE 40. ShopScene - Buying an item 

 

5.6 Plugin UI  

For the ease of use of the asset package created for this project, it was decided that the simplest 

possible way of using the functionality of the package would be to include a user interface. No best 

practices for an asset package specific UI were found in the Unity documentation but based on 

usage of other packages with a custom UI, and the Unity documentation for creating the UI, it was 

deduced that the UI should go under the ”Window” menu in the Unity Editor (27.). (Figure 41.) 

(Figure 42.) 
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As some of the asset packages used in the project already had their own menus, they were not 

added under the new menus as to avoid possible complications with future updates of the packages 

and to avoid license infractions. 

 

The aim for the UI was to provide the simplest possible user experience and as such, integrating 

as much automation as possible to the menu windows was attempted to hasten the workflow. An 

example of this can be found in the push notifications menu, which provides a ready snippet based 

on the users’ selection in all the provided options for the notification, such as the visual type and 

color. 

 

 

FIGURE 41. The Unity Essentials menu in the Unity Editor 

 

FIGURE 42. Example of custom UI 
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The custom UI and the tools for creating it are all held in the UE_Menu script and the functionality 

of the different menu options are in their own methods, while the OnGUI method holds the 

visualization of the menus. (Figure 43.) (Figure 44.) Based on the functionality of the OnGUI method 

that the Unity library offers, a switch case system was decided upon to make it possible to keep all 

the UI code under the same script for the ease of access. 

 

 

FIGURE 43. UE_Menu.cs - An example section of the OnGUI method 
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FIGURE 44. UE_Menu.cs - An example of UI functionality methods 
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6 CONCLUSION 

The aim of the thesis was to create an asset package for future OGL students, which would help 

them implement relevant mobile game functionalities, such as monetization, cloud saving and 

analytics in the fastest way possible. During the later stages of the project, a workshop for current 

OGL students was held to instruct students and test the implementation speed of the asset 

package. While the asset package was created successfully, its effects on OGL projects could not 

be documented in the timeframe. 

 

Making sure that the package and its components stayed compatible when Unity and the 

components received updates proved a challenge at times, especially as the updates to Unity 

changed some core functionality which resulted in errors with the components. 

 

The project taught both of us how to create asset packages in Unity and how to use the custom 

window system to build a corresponding UI. In addition, integrating the GPGS gave us a much 

deeper understanding of the Google Play Console and its features. As the project and thesis were 

done in a group, we also learned valuable communication and teamwork skills. 
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1 PREREQUISITES 

DISCLAIMER 

The asset package has been tested working with Unity version 2018.2.17f1 and the included 

versions of other plugins. Updating should be safe, but if something breaks, it is likely caused by 

the updates. 

 

A Google Play developer account is required for accessing most of the functionality provided by 

the asset package. This account costs 25$ as of the writing of this manual (18th of April 2019). 

Registering for the account can be done here: https://developer.android.com/distribute/console. 

 

1. After registering the account, open the Google Play Console and create a new application 

with the necessary information 

a. To finish adding a new application, you need to provide a build of your project to 

go through content rating. Adding an unfinished version of your game is okay, as 

you can keep the release hidden from the public. Remember that the package 

name in your Unity build settings must match the package name in the 

application info in the Console! 

2. In addition, you need to create a matching game under the “Game services” section 

a. You can add testers to your game here. In addition to access to the game, it should 

also allow making IAP test purchases for free.  

 

 

 

 

 

 

 

 

 

 

 

 

https://developer.android.com/distribute/console
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3. Finally, copy your SHA1 key from your application. 

a. Go to Release management → App signing to find the key 

 

 

b. Open Game services → Game details and scroll down to find the link to the API 

console and open it. 

c. From the API console, open the Credentials tab → Create credentials → OAuth 

client ID. Paste the SHA1 key and fill in the package name. 
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2 INSTALLING 

1. Download the asset package from https://bit.ly/2KKbs3j 

2. Create or open your Unity project and install the package with 

a. Assets → Import Package → Custom package 

 

 

 

3. Change build platform to Android if you haven’t already 

a. File → Build Settings → Switch Platform This step can take a long time! 

 

4. Enable Ads and IAP in the Services window 

a. If the window isn’t visible, you can open it by pressing CTRL + 0 

b.  The key required for enabling Unity IAP is under your application in the 

https://bit.ly/2KKbs3j
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 Google Console → Development tools → Services & APIs 

 

 

5. Please note that if you get errors related to Ads or IAP at this point, saving and 

restarting Unity should fix the problem. 

2.1 Setting up Google Play in Unity 

1. Go to Window → Google Play Games → Setup → Android setup 

a. Paste in the resources from the Google Play Console. The resources can be found 

in several locations in the Console, but for now get it from Game Services → 

Leaderboards → Get resources (Small link on the bottom of the panel) 
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3 HOW TO USE 

3.1 UEGameObject 

All features require the UnityEssentials gameobject to be present in the scene, as such it’s 

recommended to add the prefab of the UnityEssentials gameobject to the first scene of the game 

before any of the features need to be used, a splash screen for example. The gameobject comes 

with a do-not-destroy script so it will carry over to other scenes after that. 

 

You can create the object from Window → Unity Essentials → Create UnityEssentials object. You 

will also need to add the name of the scene you added the object to into to the UESaveManager, 

found in the object.  

 

3.2 Sign in 

You can create a Sign in object from Window → Unity Essentials → Sign in. You can either use 

the manual or automatic sign in, but automatic is the default and should be used if there’s no 

specific reason not to. You will need to tell the object which scene it loads after the sign in is 

successful you can do so by writing the name of the scene in the LevelToLoad field, located in the 

SignIn object. 

 

3.3 Leaderboards 

You can add the leaderboards button from Window → Unity Essentials → Leaderboards → 

Create. The button will open the leaderboards interface showing all leaderboards created in the 

Google Play Console for this project. To update leaderboards, you need to use the 

EULeaderboardManager’s UpdateLeaderBoard() function giving it the score and leaderboardID as 

parameters. You can find the leaderboardID from Google Play Console.  
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3.4 Achievements 

 

To give players any Achievements, you first need to create them in the Google Play Console under 

Games services → Achievements → Add new achievement. To unlock an achievement, you can 

use UEAchievementScript’s UnlockAchievement() function giving it the AchievementID as 

parameter. You can find the AchievementID from Google Play console. 

 

3.5 GameAnalytics 

You can use the GameAnalyticController’s different functions to send data to GameAnalytics. The 

BusinessEvent function handles In-App Purchases supporting receipt validation on GA servers. 

ResourceEvent manages the flow of virtual currencies – like gems or lives. ProgressionEvent 

handles level attempts with Start, Fail & Complete event. ErrorEvent submits exception stack 

traces or custom error messages, and finally DesignEvent submits custom event ID’s. Useful for 

tracking metrics specifically needed for your game. 

 

GameAnalyticsController.BusinessEvent(string currency, int amount, string itemType, 

string itemID, string cartType, string receipt, string signature); 

 

Use business events to track real money transactions in your game. You can include information 

such as the type of the purchase and where it was made. Currency is the real-world currency that 

is used for the purchase. The item type can be anything that you are selling in your game, for 

example extra lives. Item ID is the ID of that specific purchase. For example, if the player purchased 

a pack of 3 lives, the ID could be lifepack3. Amount is the amount of currency the player pays. You 

can also include receipt and signature data for purchase validation. 

 

GameAnalyticsController.ResourceEvent(GAResourceFlowType resourceFlowType, 

string currency, int amount, string itemType, string ItemID); 

 

Use resource events to track whenever player gains or loses virtual currency. Flowtype is either 

sink or source, whenever the player gains virtual currency it’s a source and whenever player loses 
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or spends virtual currency, it’s a sink. Currency is the name of the currency associated with the 

transaction. Amount is the amount of currency earned or spent. Item type and Item ID are used for 

recognizing the specific event that triggered the resource change. For instance, if a player would 

buy a boost in the game for 5 jewels, then flowtype would be sink, currency jewels, amount 5, 

itemType boost and ItemID chaosboost for example. 

 

GameAnalyticsController.ErrorEvent(GAErrorSeverity errorSeverity, string 

errorMessage); 

 

User error events to log errors and warnings generated by a player’s actions in game. Severity 

determines the severity of the error, from warning to critical and the message is used to determine 

what exactly went wrong. 

 

 

 

 

GameAnalyticsController.ProgressionEvent(GAProgressionStatus progressionStatus, 

string progression1, string progression2, string progression3, int score); 

 

Use progression events to track player progression in game, such as starting a level or finishing a 

level. The event follows a 3-level hierarchy structure to indicate a player’s path and place in the 

game. Progress can mean many things, such as level ups, quest completions, milestones etc. You 

should only track one of these with progression events, even if your game has milestones and level 

ups use progression events for the more significant one. You can use Design events to track the 

less significant progression metrics.  

 

GameAnalyticsController.DesignEvent(string eventName, float eventValue); 

 

Use design events to track whatever else you need to track in your game. Event ID’s are strings 

separated by colons that define and event hierarchy, for example LevelName:potionsUsed. Please 

note that the maximum number of unique nodes a custom event generates should not be over 10k. 

For instance, LevelName could be 100 different values in your game and the number of potions 

used in those levels could be 100 different values and you’d reach the 10k total nodes. But, if you 

would add the amount of health healed by those potions which could be around 500 different 
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values, you’d easily reach 5 million nodes. You can estimate the number of nodes by multiplying 

the estimated values of each stage of the hierarchy tree, earlier example would therefore be 

100x100 = 10 000 or 100x100x500 = 5 000 000. 

3.6 Ads 

You can create a Unity Essentials ads object from Window → Unity Essentials → Ads. You can 

choose between interstitial or incentivised ads. Furthermore, you can select between two types of 

interstitials, automatic and automatic with requirements. The automatic version runs an ad every 

time the user goes into the scene you add the ad to. The other version can be used for finer control, 

allowing you to display the ad every fifth time the scene is accessed for example. This can be 

achieved by setting the value of the UEDisplayInterstitialNext variable to 

UEDisplayInterstitialNext.Do. After displaying the ad, the system will automatically reset the 

variable. Lastly, you can use incentivised ad button, where the ad is played when the button the 

script is tied to is pressed. The button requires a public function to call, if the ad plays successfully. 
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3.7 IAP 

For IAP, you can make use of the built-in system provided by Unity IAP we set-up earlier in the 

manual. To add a button to your scene which can be used for buying items, go to Window → Unity 

IAP → Create IAP Button. To use the button, you need to provide it with a product ID and a public 

function to call when the purchase is completed and optionally/preferably a function to call on failure. 

The example scene provides an example of how the function being called after a purchase works, 

but you will need to make your own depending on the functionality your own game requires. 

 

  

 

1. To provide the button with the product ID, you first need to create products to sell for your 

game on Google Play Console. 

a. Go to Store presence → In-app products → Managed products to create new 

things to sell. You can also create subscription-based services from the In-app 

products menu, but that is outside the scope of this manual. 
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b.  After creating the items you need, copy their IDs and open the Unity IAP Catalog 

from Window → Unity IAP → IAP Catalog and fill in the info you need and paste 

the IDs. 

 

c. Finally, choose the created item in the Unity IAP Button. 

3.8 Cloud saving 

Cloud saving in and of itself is a rather complicated thing, but with the functions provided by the 

package, you don’t need to worry about any of that. To enable cloud saving in your project, all you 

need to do is add the UnityEssentials object to the first scene in your project as instructed earlier 

as the object comes with the necessary scripts for saving. To manually save (there is no automatic 

saving) the players project, simply use the code provided in the Window → Unity Essentials → 

Cloud Saving menu. There are several places where data needs to be saved, such as after clearing 

levels and buying items in the shop. To make sure nothing the players does, or gains is lost, think 

hard of where to place the save points in your game. 
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3.9 Push notifications 

To use push notifications, simply open the corresponding menu from Window → Unity Essentials 

→ Push Notifications, fill in the choices and copy the automatically generated code into your own 

scripts. To schedule the notifications, you need to build your own system that suits the type of 

scheduling you want. 

 

 


