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ABSTRACT 

 

  The aim of the Bachelor’s thesis was to make a research on foundations, 

explore the different types and the cases in which they are applicable and 

to create a custom-made foundation report of a test model in a step by step 

structure. The model which was used is provided by the Website of Tekla 

Corporation. The thesis also gives general information about Tekla Struc-

tures and projects which were executed with the help of the software.  

 

  The theoretical part of the thesis was collected from various sources. It 

includes general information about Tekla Structures, a short explanatory 

information on what reports are in Tekla Structures and how to use them, 

and research on the different foundations and their advantages.  

 

  The practical part of the thesis involves the creation of a custom founda-

tion report of a test model. The report was done using the Template Editor 

tool of Tekla Structures software. Tekla Structures was used as a main re-

search tool. 

 

  As a result of the thesis, a step by step guide on how to create a custom 

report in Tekla Structures was formulated. The guide can serve as a future 

reference to new users of Tekla.  
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1  INTRODUCTION 

  Building Information Modelling (BIM) is a model-based process of 

creating and managing building data during the building’s life cycle. 

BIM helps architects, engineers and constructors apply the same ap-

proach to building and infrastructure projects, i.e. it enables a more col-

laborative process. (Autodesk, 2011) With BIM (Building Information 

Modelling) technology, one or more accurate virtual models of a build-

ing are constructed digitally. They support design through its phases, al-

lowing a better analysis and control than manual processes. When com-

pleted, these computer-generated models contain precise geometry and 

data needed to support the construction, fabrication, and procurement 

activities through which the building is realized. (Eastman, Teicholz, 

Sacks & Liston 2011)  

 

  The objective of this thesis is to explore one of the possibilities that the 

BIM, Tekla Structures in particular, provides. Creating custom reports is 

a useful and a highly valuable option. Even though the procedure is ra-

ther easy, it requires knowledge. There aren’t many free tutorials availa-

ble and therefore the main purpose of the thesis is to provide an easy-to-

follow guide on how to create a report using the Template Editor tool 

from Tekla, a foundation report in particular. Reports are a very im-

portant part of the construction process, especially for cost-estimation 

purposes. The scope of the thesis is limited only to a foundation report 

on a test model, created with Tekla Structures. 

 

  The process of writing the thesis began with defining the objectives by 

the supervisor and the author. Data and information regarding Tekla 

Structures, BIM in general, different types of foundations and lastly – 

the Template Editor tool from Tekla, was gathered from various sources 

and then put together. The next step was to create the actual report and 

to document each step of it. Lastly, the report was generated according 

to the specific model. 
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2 TEKLA STRUCTURES SOFTWARE 

2.1 Tekla Overview 

  Tekla Structures is a 3D building information modelling (BIM). It is 

widely used for steel and concrete detailing, precast and in-situ cast con-

crete by structural engineers, detailers and fabricators in the construction 

industry. Tekla enables the users to model anything from stadiums and 

residential buildings to bridges and skyscrapers since it works with all ma-

terials and models of all complexity. The software also gives its users the 

opportunity to cover the entire building process from concept to the actual 

fabrication. Tekla Structures has different configurations in order to meet 

a wider range of its costumers’ needs. Having 30 localized environments 

and 14 user interface languages as well as a special configuration for stu-

dents has made the use of the software easy and accessible (Tekla). Figure 

1 below shows an example of a Tekla model 

 

 

Figure 1 Tekla Example Model (www.tekla.com) 

2.2 Projects execution with Tekla 

  Tekla Structures has been preferred as a solution to many big and im-

portant projects. Its diverse tools and options allow the users to use Tekla 

in various situations and to solve many different problems. 

2.2.1 Manskun Rasti Project 

  One of Tekla’s big projects was the Manskun Rasti one in 2012 – a com-

plex of four office buildings in Helsinki, Finland. The main contractor of 

the project was Skanska, which is a world leading project development 

and construction group. An information model was created for each stage 

of the construction. The first model that was created represented the 

earthworks and the foundation construction. Its purpose was to visualize 

http://www.tekla.com/
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the construction work phase by phase from the soil excavation to the 

foundation casting as well as to help organize the schedule using Tekla 

task manager. The second model included the construction of the under-

ground floors. Moreover, Tekla modelling was used for planning logistics 

and work safety as well as quantity surveying.  

 

  The Manskun Rasti construction site in Helsinki, Finland, is a showcase 

of the future. Skanska has taken the building information modelling pro-

cess to a new dimension by boldly putting the limits and possibilities of 

BIM to the test. Manskun Rasti is the winner of the Tekla Global BIM 

Awards 2011 competition in the Building Information Modelling catego-

ry. According to the jury, utilization of building information modelling has 

been ground-breaking in the project. The building trade magazine Ra-

kennuslehti awarded Manskun Rasti the title of Construction Site of the 

Year 2011, largely thanks to the use of the building information modelling 

(www.tekla.com). Figure 2 below shows the Manskun Tekla model. 

 

 

Figure 2 Maskun Rasti Tekla Model (www.tekla.com) 

2.2.2 Puuvilla Project  

  Another very impressive project which was created with the help of 

Tekla Structures is the Puuvilla Project. Porin Puuvilla used to be a cotton 

factory one hundred years ago which was turned into a shopping center in 

2014. The center combines both old and new structures as well as housing 

retail,  offices and parking space. Thirteen different project parties were 

http://www.tekla.com/
http://www.tekla.com/
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involved in the construction of the shopping center. The construction was 

involved with a very tight schedule and the key to keeping it was that 

instead of using emails and paper as a communication tool, models were 

used. Thanks to the models made with Tekla Structures, contracting 

offices situated in different parts of the country were able to communicate 

with each other and work on the same project (Tekla). Figure 3 shows a 

picture of the Puuvilla Tekla model. 

 

 

Figure 3 Puuvilla Tekla Model (www.tekla.com) 

2.3 Reports in Tekla Structures 

  The Tekla Structures Software provides the users with the option to cre-

ate reports based on the information used in the models. These reports are 

directly created from the model, thus the extracted information is always 

accurate. Tekla reports give information about either the whole model or 

certain parts, they could be lists of drawings, assemblies, parts, materials 

used, etc. Many standard report templates which are ready to use are in-

cluded in the software. In case that one needs to modify an existing report 

or create one according to one’s specific needs, (www.tekla.com) Tekla’s 

Template Editor can be used. How exactly the reports are being extracted 

has been explained more in depth later on in the thesis. The relation be-

tween reports and templates is to be found in Appendix 1. Figure 4 shows 

the Drawings & Reports window in Tekla and figure 5 – an exemplary re-

port. 

 

http://www.tekla.com/
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Figure 4 Drawings & Reports in Tekla 

 

Figure 5   Exemplary Report (www.tekla.com) 

http://www.tekla.com/
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2.4 Template Editor 

   In order to serve the purpose of this thesis, the Template Editor option 

from Tekla Structures was used to create a foundation report. The Tem-

plate Editor can be run from Tekla as well as on its own as a standalone 

program. It is used to produce reports, labels and legends. Using the Tem-

plate Editor, both Textual and Graphical Templates can be created. The 

Graphical templates are generally used to present map legends and labels 

as well as project and company information and they can also contain ta-

bles, pictures and symbols. The textual templates on the other hand only 

contain text. Since they are used for creating reports - that is the tool that 

was used for creating the foundation report for the thesis 

(www.tekla.com). Figure 6 below shows the Tekla Template Editor win-

dow in Tekla. 

 

 

Figure 6 Tekla Template Editor 

3 FOUNDATIONS 

  The foundation is a part of the structure the purpose of which is to trans-

mit the load of the building to the ground lying underneath. It is always 

built below the ground level in order to increase the lateral stability of the 

whole structure. Every building usually has numerous individual founda-

tions, which are called “footings” and each column lays on its own foot-

ing. Thus, a foundation is a connecting link between the structure and the 

ground that supports it.  

 

  Since the whole weight of the building rests on the soil, its properties and 

safe bearing capacity need to be carefully examined and determined in or-

der to ensure that it can carry the imposed loads of the structure. The SBC 

http://www.tekla.com/
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is the capacity of the soil to support the loads imposed to the ground, i.e. it 

is the amount of weight per unit that the soil can bear. This capacity 

changes according to the depth. The general rule is that the deeper it gets, 

the greater the SBC, although this is not always the case, because there 

might be “pockets” of weak soil in the earth. Usually, the soil near the sur-

face is weak and loose and for the proper support of the building, strong 

and firm soil is needed. That is the reason why the building contractors dig 

until this strong and firm soil is reached.  

 

  All engineering structures need foundations because of the following rea-

sons: 

 

 Prevention of lateral movement of the supporting material  

 Distribution of the load of the structure over a big bearing area 

 Loading the bearing surface uniformly in order to prevent unequal set-

tlement 

 General increment of the stability of the structure 

 Securing a firm bed for building operations 

 

Broadly said, foundations are classified into two main categories: shallow 

and deep foundations.  

3.1 Shallow Foundations 

  The shallow foundations, as their name suggests are constructed at a 

shallow depth below the ground surface or below the deepest basement of 

a building. They can be used only in case that the soil at the level where 

they are built can adequately support the load. Shallow foundations also 

need to be placed below the frost line, which means that the soil needs to 

be excavated, until this particular level is reached, although there are also 

the so called frost-protected shallow foundations, which provide the nec-

essary protection against frost damage and do not require specific place-

ment below this frost line. Shallow foundations are further classified into 

the following four categories of strip foundations, pad footing, raft founda-

tions and strap or cantilever footing. These will be discussed in the follow-

ing chapters. 

3.1.1 Strip Footing 

  Also known as a continuous footing, the strip footing is a popular solu-

tion for supporting load-bearing walls or for a row of columns the spread 

footings of which are too closely positioned or nearly touch each other. In 

such cases the strip footing is a more economical solution. Strip founda-

tions are usually used in cases where the loads are being carried by entire 

walls instead of columns. It is a solution only where the soil has good 

bearing capacity. The size and the position of the strip foundation depends 

on the overall width of the wall that is being supported. Figure 7 below 
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shows a drawing of a strip footing, and Figure 8 shows a strop footing of 

an actual house. (http://buildgood.blogspot.fi) 

 

Figure 7 Drawing of a strip footing (http://www.builderbill-diy-help.com/strip-

footing.html) 

 

 

 

Figure 8 Strip footing of an actual house (http://buildgood.blogspot.fi) 

http://buildgood.blogspot.fi/
http://www.builderbill-diy-help.com/strip-footing.html
http://www.builderbill-diy-help.com/strip-footing.html
http://buildgood.blogspot.fi/
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3.1.2 Pad Footing 

  The pad footings, or individual or spread footings as they are also known, 

are the most common and simple types of foundation solutions. They are 

used to support columns and usually each column is supported by an indi-

vidual concrete pad footing. The footings are isolated, or in other words, 

there isn’t any connection between them. The pad footings are a good so-

lution for a light-weight timber-framed houses. Figure 9 contains a draw-

ing of a pad footing and Figure 10 shows how the pad footings during 

construction.  

 

 

Figure 9 Drawing of a pad footing (http://civilblog.org/wp-

content/uploads/2014/10/pad-footing.png) 

 

http://civilblog.org/wp-content/uploads/2014/10/pad-footing.png
http://civilblog.org/wp-content/uploads/2014/10/pad-footing.png


Reporting in Tekla Structures 

 

 

 

10 

 

Figure 10 Pad footings during construction (http://propertyforsalephuket.co.th/wp-

content/uploads/2010/12/Footing-pads.jpg) 

3.1.3 Raft Foundations  

  Also known as mat foundation, the raft foundation is a big slab extending 

below the entire building and supporting all the walls and columns. It can 

be used for the whole building or only partially. The raft foundation is 

usually used for office or public buildings or where the soil conditions are 

very poor – the bearing capacity is low and individual footings cannot be 

used.  

 

 

Figure 11 Raft foundation (http://www.builderbill-diy-help.com/image-files/concrete-

raft-foundation.jpg)  

http://propertyforsalephuket.co.th/wp-content/uploads/2010/12/Footing-pads.jpg
http://propertyforsalephuket.co.th/wp-content/uploads/2010/12/Footing-pads.jpg
http://www.builderbill-diy-help.com/image-files/concrete-raft-foundation.jpg
http://www.builderbill-diy-help.com/image-files/concrete-raft-foundation.jpg
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3.1.4 Strap or Cantilever Footing 

  A strap footing is when two independent pad footings are connected by a 

beam. The strap beam is not in contact with the soil, which means that it 

will not transfer any pressure to the soil underneath. It serves as a distribu-

tor of load between both columns which then transfer the loads onto the 

soil. The strap footing is used as a solution when for example, a column 

lies close to the property limit and the distance between this and the ad-

joining column is too big. Figure 12 shows a drawing of a strap founda-

tion. 

 

Figure 12 A drawing of a strap foundation 

(http://upload.wikimedia.org/wikipedia/commons/4/49/Strap_footin

g.jpg Assessed 28th January 2015)  

3.1.5 Combined Footing  

  The combined footing provides support for two or more columns. Build-

ing individual, or pad footings is less cost effective rather than building a 

combined footing. That is why combined footings are selected as a solu-

tion only when it is inevitable – when two or more columns are too close 

together or when a column is too close to a property line and it needs to be 

combined with an interior column. Figure 13 below shows a drawing of a 

combined footing. 

 

http://upload.wikimedia.org/wikipedia/commons/4/49/Strap_footing.jpg%20Assessed%2028th%20January%202015
http://upload.wikimedia.org/wikipedia/commons/4/49/Strap_footing.jpg%20Assessed%2028th%20January%202015
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Figure 13 A drawing of a combined footing 

(http://images.books24x7.com/bookimages/id_15273/fig337_02.jpg )  

3.2 Deep Foundations  

  Deep Foundations are used to transfer the load from a given structure 

through the weak and compressible soil to a deeper stronger soils or rocks 

with better bearing capacity. The reason for using them can be either the 

lack of strong soil which can provide adequate support for the structure or 

limited property lines. Deep foundations have been classified into two cat-

egories i.e. pile foundation and caisson foundations.  

3.2.1 Pile Foundation 

  The pile foundation is a necessary solution when the soil which is at the 

surface is weak and cannot provide the support that the structure needs, 

when building in marine conditions, or when the building has very big 

concentrated loads. The piles are made of a strong material such as con-

crete and are being pushed deep into the soil so that they would bypass the 

weak soil in order to reach the strong soil or rock underneath where the 

loads will be transferred. They can take bigger loads than the spread foot-

ings. The pile foundation usually consists of a base, the so called pile cap, 

which is supported by the piles underneath. There are two types of pile 

foundations, the choice of which depends mainly on the soil condition, the 

load of the structure and the cost budget. Figure 14 shows a drawing of a 

pile foundation.  
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Figure 14 A drawing of a pile foundation 

(http://osp.mans.edu.eg/deepfoundation/ch1.files/image030.jpg)  

  The end bearing piles are used when the solid bedrock is within a reason-

able depth from the surface and so the loads are being transferred directly 

to the underlying soil. Friction piles on the other hand are used when the 

solid soil is at a greater depth and thus, the use of end bearing piles 

wouldn’t be cost efficient. The friction piles’ surface is in friction with the 

soil and it thus resists the loads from the structure. The difference between 

end bearing and friction piles is shown in Figure 15. 

  

 

Figure 15 The difference between end bearing and friction piles 

3.2.2 Caisson Foundations  

  Another type of deep foundation is the caisson, which is also known as a 

pier foundation. They are very strong and are capable of supporting very 

big concentrated loads. The foundation consists of a large cylindrical col-

http://osp.mans.edu.eg/deepfoundation/ch1.files/image030.jpg
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umn through which the loads are being transferred to the strong stratum 

underneath. They are a perfect solution for a house which is on a hill for 

example. The pier foundations may differ from each other. There are dif-

ferent types like a masonry pier and drilled caisson. In general, the pier 

foundation works by drilling a shaft into the soil which is then reinforced 

with steel and concrete is being poured inside the shaft. Figure 16 shows a 

picture of masonry pier and of drilled caisson concrete. 

 

Figure 16 Caisson foundations (www.abuildersengineeer.com) 

4 TEKLA MODEL 

   For the purpose of the thesis, the foundation report was executed on a 

test model, available for download in the Tekla Campus website 

(https://campus.tekla.com/introduction-drawings). The structure is a four-

storey building and has a steel frame and cast in-situ concrete slabs. It is 

supported by strip, or also known as continuous, foundation and concrete 

piles with pile caps – both rectangular and trapezoidal ones. The piles 

have a diameter of 600mm. The pile caps are reinforced and so are the 

strip footings. More detailed drawings of the model are to be found in Ap-

pendix 2. Figure 17 shows the Tekla Campus test model. 

 

 

 

 

 

http://www.abuildersengineeer.com/
https://campus.tekla.com/introduction-drawings
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Figure 17 Tekla Campus Test Model 

5 REPORTING IN TEKLA STRUCTURES 

5.1 Creating Reports in Tekla 

Tekla Structures has provided its users with a number of standard report 

templates. These can easily be accessed by clicking Drawings & Reports 

and then Create Report. Then, a report template needs to be chosen from 

the list – anything from rebar reports, weld lists, to assembly and drawing 

lists. Under Titles in reports, the titles can be entered and the file can be 

renamed in the Name box. From the Options tab, certain settings may be 

modified. The report may now be created either from the entire model by 

clicking Create from all or it can be run from selected objects only by 

clicking the Create from selected (www.tekla.com). Figure 18 shows the 

report window in Tekla and the list of the ready-to-use template reports. 

 

http://www.tekla.com/
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Figure 18 Report generator in Tekla 

 

  Below in Table 1 the different report options are explained. 

Table 1 Report Options (www.tekla.com) 

 
 

5.2 Creating a Foundation Report with Template Editor 

  The report that was created with Tekla’s Template Editor is a foundation 

report. It gives information about the formwork area, the concrete volume, 

the weight of the concrete and the identification number of each member 

http://www.tekla.com/
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in the model. It was done in a step by step structure in order to be as sim-

ple as possible and to enable a better understanding for the reader.  

 

1) The first step to creating a report is to open the Template Editor from 

Tekla in Drawings & Reports. This will open the Template Editor in 

a new window. To create a new report File must be selected and then 

New and then Textual. The default background of the Template Editor 

is white which is not practical because whenever there are letters in 

lighter colors such as yellow for example, they are not clear and visi-

ble enough. Therefore a better option is to use a grey background. This 

can be changed by going to Options -> Preferences -> Workarea. By 

double clicking the background Template Page Properties can be ac-

cessed and the size of the working area can be modified.  

2) To create a header click Insert -> Component -> Header. This cre-

ates a header at the top of the working area. Its size can be changed by 

clicking and dragging the small white cubes situated at the center of 

the header. The header provides general information about the report 

such as its name, company’s name, date, etc. Figure 19 shows what the 

template should look like at this stage. 

 

 

Figure 19 Header of the report 

 

3) To give a name to the report click Insert and then Text. This opens a 

box to enter the text. After that it can be placed anywhere in the head-

er. The following information was added to the foundation report :  

 Report title  

 Project title  

 Company name/University 

By double clicking the existing text the content and the font of the text 

can be changed. For this report Courier New font was used. Figure 20 

shows how the titles have been placed in the template.  
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Figure 20 Inserted text in the header 

 

4) After the text has been entered, value fields can be added. Unlike the 

text, the value fields pull information from the model and insert it into 

the report. A value field was added to the Project Title and also a date 

value was added. To add a value field press Insert -> Value Field. 

This opens a list of attributes from which the correct one was chosen – 

Date (Fig. 21) and Project -> Name. When double clicking on the 

value field its properties can be seen and changed – name, data type, 

unit, etc. For aesthetical reasons, an equal sign was added as a border 

at the bottom of the header. 

 

 

Figure 21 Add date value field 
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  After all the text in the header has been added as well as the value fields, 

the template looks as shown in Figure 22. 

 

 

Figure 22 Finished header 

 

5)   After the basics of the report is done, a new Row can be created. The 

row contains text and the extracted information from the model. A new 

row can be created by clicking Insert -> Component -> Row. This 

opens a Select Content Type window where it is of high importance 

that the correct content type is chosen (Fig 23). The first row contains 

only textual information :  

 Name Of The Item 

 Formwork Area 

 Concrete Volume 

 Concrete Weight 

 Item ID (Identification Number) 
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Figure 23 Select content type 

 

  The content type for this report is CAST_UNIT. The next step is to add 

the textual information. This is done by clicking Insert -> Text. The text 

needs to be positioned so that there is space for everything and so that 

nothing is overlapping. Figure 24 shows the finished row with textual 

information. 

 

 

 

Figure 24 Row with textual information 
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6) After specifying the title and placement, the values themselves can be 

added. For that purpose, a new Row is needed – Insert -> Component 

-> Row. The content type is CAST_UNIT. The first value that was 

added is the name of each object. This is done by clicking Insert -> 

Value Field and then choosing the corresponding value (Fig. 25 and 

Fig. 26). This applies for the concrete volume, weight and ID. The 

Formwork Area includes the length and the area of the concrete mem-

ber. After all the values have been chosen, they need to be positioned 

correctly and correspondingly to the previous Row. 

 

 

 
    

Figure 25 Adding "Name" value field 

 

 

 
 

Figure 26 Adding "Volume" value field 

 

   The Name Value Field can be double clicked which will open up a 

window with its properties. From there, the sorting was set to Ascending – 

this will sort all the parts in an alphabetical order (Fig. 27). Also, the char-

acter’s length was decreased to 10 characters in order to take up less 
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space. This, however, has only aesthetical importance and does not change 

the output of the report.  

 

 

Figure 27 Changing the order to ascending 

  The ID Value Field allows one to make the report interactive. This gives 

the advantage of being able to click on a certain item from the report and 

by doing so the item is also being selected and highlighted in the model. 

That helps, for example, to easily make multiple changes such as renam-

ing more than one object. 

 

   By double clicking the Row containing the value fields, the Row proper-

ties can be accessed. From there, the Sort Type was changed to Distinct 

(Fig. 28). In that way, every item is listed separately whereas if the Com-

bined option is selected, all of the items from the same type will be com-

bined together as well as their value fields such as length, volume, weight, 

etc.  
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Figure 28 Changing the sort type of the row to "Distinct" 

 

After all the values are added, the report looks like this as shown below in 

Figure 29. 

 

 

Figure 29 Report 

 

7) The next step of creating the report is to add a Footer. The Footer will 

be used to summarize all the values, in the particular case – Formwork 

area (length and area), concrete volume and weight. To add a Footer 
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click Insert -> Component -> Page Footer. This opens a green box at 

the bottom of the report (Fig. 30). Then text is added (Insert -> Text) 

underneath the relevant values, in this case – Total Weight and Total 

Volume.  

 

 

 

Figure 30 Adding a footer 

 

  Next, Value Fields are added next to the previously added text. 

These can be copied from the above standing Value Fields (Volume 

and Weight) and then pasted, or they can be added by clicking Insert -

> Value Field. In figure 31 the positioning of the added text and value 

fields can be seen. 

 

 

Figure 31 Adding value fields to the footer 
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  In order for the report to be able to calculate the total volume or re-

port, a different command needs to be used in the attribute.  

 

  By double clicking the Volume Value Field which was used in the 

previous row, the Value Field Properties can be accessed. Under 

Format and then Name the data has to be copied (Fig. 32).  

 

 

Figure 32 Copying the format name of the value field 

 

  After the name is copied from the Value Field Properties of the 

Volume, the Value Field Properties of the Total Volume needs to be 

opened. There, all the data that is written under Formula needs to be 

deleted. After that, by clicking the Formula button underneath, a new 

window called Formula Contents is opened (Fig. 33).  



Reporting in Tekla Structures 

 

 

 

26 

 

Figure 33 Deleting the formula content 

 

  In the Formula Contents a drop down menu Function can be found 

under Value Field. From there, Sum option needs to be chosen (Fig. 

34). 
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Figure 34 Choosing SUM function 

  In the same window, under the drop down menu, the previously 

copied data from the Volume needs to be pasted into the brakets as 

shown in Fig. 35. 

 

 

Figure 35 Pasting the data into the formula field 

 

  The same must be done for the Total Weight as well, this time copying 

and then pasting the formula from the Weight value. The last step 

concerning the Footer is to double click it so that the Page Footer 

Properties opens. From there, the output policy needs to be set to Last, so 
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that the Total Volume and the Total Weight appear at the bottom of the 

repor (Fig. 36). 

 

  

Figure 36 Changing the footer properties 

 

8) After all the previous steps are made, the report needs to be saved by 

clicking File -> Save As. The report needs to be given a name. After 

that, it can be used in Tekla. 

 

9) Before the report can be generated, the parts included in the report 

need to be chosen. Since this report is a foundation report, only the 

foundation parts will be selected. Once they have been selected and 

highlighted in Tekla, the report can be generated. In order to run the 

report click Drawings & Reports -> Create Report or the shortcut 

command Ctrl+B. (Figure 37) 
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Figure 37 Create report in Tekla 

 

 

Once the list with reports is opened, the Foundation Report needs to 

be found. The last step is to click Create From Selected, since the 

report is regarding foundations only. This will generate the report in a 

separate window, as shown in Figure 38. 

 

 

 
  

Figure 38 Create report from selected members 

6 CONCLUSION 

  As a main result of the thesis a step by step guide on how to create a 

custom report using Tekla’s tool Template Editor was created. The 

guide provides vast and detailed information on every step of the proce-

dure and covers the most important techniques. It is written in an acces-

sible manner so that it can be easily understood by users who are new to 

Tekla Structures. All the steps were visualized by photos of the actual 

process. The final generated report is to be found in Appendix 3. Being 

able to create a custom report according to the user’s needs is an im-

portant skill because it gives the user more flexibility and independence. 
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Custom-made reports are needed daily in the construction field and thus, 

being able to create one would be a beneficial skill for one’s carrier. 

 

  The thesis also presented an introduction to Building Information 

Modelling and its advantages. Furthermore, it gives us information on 

what Tekla Structures is and on two of its big projects.  

 

  The research on the different types of foundations provides a good 

summary of the general and most important principles about founda-

tions. It gives knowledge of what types of foundations there are, about 

their stability and the cases in which they are used.  
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TEMPLATES AND REPORTS  
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                  Appendix 2 

TEKLA TEST MODEL DRAWINGS 

 

 

Figure 39 Piles with pile caps 

 

 

Figure 40 Top View Plan 
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FOUNDATION REPORT 
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